memo/shell.nix
2025-01-23 20:54:26 +01:00

25 lines
459 B
Nix

{
pkgs ? import <nixpkgs> { },
}:
with pkgs;
mkShell {
buildInputs = [
redis
bun
];
shellHook = ''
echo "
__ __ ___ __ __ __
| V | __| V |/__\
| \_/ | _|| \_/ | \/ |
|_| |_|___|_| |_|\__/
"
export BUN_INSTALL="$HOME/.bun"
export PATH="$BUN_INSTALL/bin:$PATH"
echo "Run 'bun install' for installing deps and 'redis-server --daemonize yes && bun run start' to start the servers"
'';
}