nixos-config/modules/minimal-server.nix
2024-09-18 11:29:27 +03:00

35 lines
554 B
Nix

# cli basic programs and configs that should be available on every server
{ config, pkgs, ... }:
{
programs.neovim = {
enable = true;
defaultEditor = true;
viAlias = true;
vimAlias = true;
};
# List packages installed in system profile. To search, run:
# $ nix search wget
environment.systemPackages = with pkgs; [
bat
btop
findutils
fzf
gnugrep
git
glances
htop
lazygit
lsd
magic-wormhole
mc
micro
mosh
neovim
ripgrep
tmux
tree
unzip
wget
];
}